System Performance Degradation

Incident Report for Alta

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 15:56 UTC

Investigating

We are currently experiencing system-wide performance issues which causes pages and data to load slowly.
Our dev team is actively working on implementing a fix
Posted Sep 03, 2025 - 13:57 UTC
This incident affected: Platform.